CocoaPods版本升级

2015/6/17 posted in  Cocoapods

命令行执行

$ pod install
[!] The 'master' repo requires CocoaPods 0.37.2 - 

失败,提示需要CocoaPods 0.37.2版本

查看CocoaPods版本

$ pod --version
0.36.3

命令行更新(安装)步骤

$ sudo gem update --system // 先更新gem,国内需要切换源
$ gem sources --remove https://rubygems.org/
$ gem sources -a http://ruby.taobao.org/
$ gem sources -l
\*\*\* CURRENT SOURCES \*\*\*
http://ruby.taobao.org/
$ sudo gem install cocoapods // 安装cocoapods
$ pod setup

和安装过程是一样的,再次查看版本

$ pod --version
0.37.2

更新结束